Autor Thema: Quellen im Wiki  (Gelesen 4231 mal)

Michael Hohner

  • Administrator
  • *****
  • Beiträge: 4848
  • Wo ist nun der versprochene Wurm?
    • Meine Spinnenfunde in Bayern
Quellen im Wiki
« am: 2009-10-18 10:09:20 »
Bin gerade auf ein noch größeres Problem gestoßen:

Wenn man im Wiki nicht angemeldet ist, dann werden keine Quellen angezeigt ("<references/>" liefert leeres Ergebnis). Das muss wohl ein Bug in der Extension sein.

Martin Lemke

  • Administrator
  • *****
  • Beiträge: 14773
  • TK 2130 Lübeck, Schleswig-Holstein, Germany
    • Spinnenerfassung in SH
Re: Quellen im Wiki
« Antwort #1 am: 2009-10-18 20:44:44 »
Wenn man im Wiki nicht angemeldet ist, dann werden keine Quellen angezeigt ("<references/>" liefert leeres Ergebnis).

Tatsächlich! Komisch, dass uns das erst jetzt auffällt.

Ich liege allerdings seit ein paar Tagen wegen einer Erkältung flach und kann mich dem im Moment nicht annehmen.

Vielleicht kannst Du im Source etwas verdächtiges finden?

Martin
Profil bei Researchgate.net

DAS waren noch Zeiten: Nowegen 2011.

Lars Friman

  • Gast
Re: Quellen im Wiki
« Antwort #2 am: 2009-10-18 21:20:50 »
Na dann gute Besserung Martin!
Lars Friman

Martin Lemke

  • Administrator
  • *****
  • Beiträge: 14773
  • TK 2130 Lübeck, Schleswig-Holstein, Germany
    • Spinnenerfassung in SH
Re: Quellen im Wiki
« Antwort #3 am: 2009-10-18 23:52:12 »
Ich bin schon auf dem Weg der Besserung (hoffe ich). Nach dem ich drei Tage vor dem Fernseher gelegen habe, zieht es mich zumindest schon wieder an den PC.

Ich habe mal ein wenig experimentell im cite-Source herum gepfuscht und habe Anweisungen auskommentiert, die Bedingungen in Zusammenhang mit Berechtigungen steuern, aber nichts davon hatte den gewünschten Effekt.

Was mich aber wundert ist, dass das Zitat in Gattungsartikeln funktioniert, aber in anderen nicht:

Referezen OK
http://wiki.spinnen-forum.de/index.php?title=Salticidae
http://wiki.spinnen-forum.de/index.php?title=Phlegra

Referenzen fehlen
http://wiki.spinnen-forum.de/index.php?title=Theridiidae

Am Fehlen oder Vorhandensein eine name-Attributs in der ref liegt es nicht, wie ich gerade ausprobiert habe.

Und noch ein Effekt: Auf der Gattungsseite LInyphiidae tritt ein Fehler nur dann auf, wenn man nicht angemeldet ist. Vielleicht hängen die Effekte miteinander zusammen?

Vielleicht hat ja jemand etwas mehr Scharfsinn als ich im Moment?

Martin
Profil bei Researchgate.net

DAS waren noch Zeiten: Nowegen 2011.

Martin Lemke

  • Administrator
  • *****
  • Beiträge: 14773
  • TK 2130 Lübeck, Schleswig-Holstein, Germany
    • Spinnenerfassung in SH
Re: Quellen im Wiki
« Antwort #4 am: 2009-10-19 10:29:32 »
Ich begreife es nicht!

Nach einiger Herumprobiererei habe ich den Eindruck gewonnen, dass die References immer dann verschwinden, wenn auf der Seite eine <gallery> exitistiert. Kann das mal jemand nachvollziehen oder versuchen zu überprüfen. Mir kommt der Fehler so zusammenhangslos vor. Vielleicht irre ich ja.

Auf der Seite Linyphiidae werden die Quellen angezeigt, obwohl eine <gallery> enthalten ist. Bei Araneus diadematus sind die Quellen zu sehen, sobald man die <gallery> auskommentiert. Der wahre Fehler muss doch zu finden sein!

Martin
« Letzte Änderung: 2009-10-19 10:32:39 von Martin Lemke »
Profil bei Researchgate.net

DAS waren noch Zeiten: Nowegen 2011.

Michael Hohner

  • Administrator
  • *****
  • Beiträge: 4848
  • Wo ist nun der versprochene Wurm?
    • Meine Spinnenfunde in Bayern
Re: Quellen im Wiki
« Antwort #5 am: 2009-10-19 10:51:31 »
Gallery und Cite sind beides Parser-Erweiterungen. Offenbar beissen sich die irgendwie.

Koennte ein Update auf 1.15.1 helfen?

Martin Lemke

  • Administrator
  • *****
  • Beiträge: 14773
  • TK 2130 Lübeck, Schleswig-Holstein, Germany
    • Spinnenerfassung in SH
Re: Quellen im Wiki
« Antwort #6 am: 2009-10-19 10:55:14 »
Anscheinend stimmen die Erkenntnisse von eben nicht. Sie treffen ausschließlich auf die Seite von A.diadematus zu.

Wahrscheinlich entscheidet sich die Tatsache, ob die Zitate angezeigt werden an der Mondphase oder wird von kleinen Geistern ausgewürfelt. Spaß beiseite. Ich finde den Fehler nicht und ich kann auch keine Kontinuität im Auftreten des Fehlers erkennen.

Ich habe auch keine Lösung parat. Ohne den Fehler irgendwie effektisch einzugrenzen, ist es sinnlos dem Autor den Fehler zu melden. Was tun?

a) Auf Zitate verzichten? => auf keinen Fall!
b) Zitate von Hand einpflegen => Dann müsste man sämtliche Seiten von Hand überarbeiten
c) Cite-Extension reparieren => Wie, ohne Fehlereingrenzung?

Hat jemand eine Idee?

Martin
Profil bei Researchgate.net

DAS waren noch Zeiten: Nowegen 2011.

pfeiffer

  • Gast
Re: Quellen im Wiki
« Antwort #7 am: 2009-10-19 11:28:00 »
Hat jemand eine Idee?

Michael. ;-) (Ihr habt sich überschnitten, denke ich.)

-K

Martin Lemke

  • Administrator
  • *****
  • Beiträge: 14773
  • TK 2130 Lübeck, Schleswig-Holstein, Germany
    • Spinnenerfassung in SH
Re: Quellen im Wiki
« Antwort #8 am: 2009-10-19 16:03:14 »
(Ihr habt sich überschnitten, denke ich.)

Ich weiß, die Forensoftware hat es mir angezeigt.

Ein Update der Wikisoftware fällt bei mir in die Kategorie "Ausprobieren" oder gibt es Erkenntnisse, die nahelegen, dass der Fehler damit zu eliminieren ist?

Martin
Profil bei Researchgate.net

DAS waren noch Zeiten: Nowegen 2011.

Michael Hohner

  • Administrator
  • *****
  • Beiträge: 4848
  • Wo ist nun der versprochene Wurm?
    • Meine Spinnenfunde in Bayern
Re: Quellen im Wiki
« Antwort #9 am: 2009-10-19 16:30:46 »
Dieses "Ausprobieren" waere aber nicht schlimmer als das bisherige "Ausprobieren". Am Ende bleibt nur, eine Beispielseite an die Wiki-Entwickler zu senden und die das analysieren zu lassen.

pfeiffer

  • Gast
Re: Quellen im Wiki
« Antwort #10 am: 2009-10-19 17:57:13 »
Dieses "Ausprobieren" waere aber nicht schlimmer als das bisherige "Ausprobieren". Am Ende bleibt nur, eine Beispielseite an die Wiki-Entwickler zu senden und die das analysieren zu lassen.

Und bei der Meldung eines möglichen Fehlers, ist es auf jeden Fall besser aktuell zu sein...

-K

Martin Lemke

  • Administrator
  • *****
  • Beiträge: 14773
  • TK 2130 Lübeck, Schleswig-Holstein, Germany
    • Spinnenerfassung in SH
Re: Quellen im Wiki
« Antwort #11 am: 2009-10-20 01:07:11 »
Wir sollten vorher versuchen herauszufinden, wann der Fehler auftritt.

Was ist in diesem Zusammenhang der entscheidende der Unterschied zwischen Linyphiidae und Araneus marmoreus?

Bei ersterem werden die Quellen angezeigt, bei zweiterem nicht. <gallery> haben beide.

Martin
Profil bei Researchgate.net

DAS waren noch Zeiten: Nowegen 2011.

Michael Hohner

  • Administrator
  • *****
  • Beiträge: 4848
  • Wo ist nun der versprochene Wurm?
    • Meine Spinnenfunde in Bayern
Re: Quellen im Wiki
« Antwort #12 am: 2009-10-20 11:18:24 »
Ich halte das fuer vergebliche Muehe, da noch ewig dran rumzudoktern. Einfach den Link fuer Araneus marmoreus an die Entwickler schicken und fragen, warum die Quellen fehlen. Die kennen sich mit dem Code am besten aus und koennen gezielt nach Ursachen suchen.

Martin Lemke

  • Administrator
  • *****
  • Beiträge: 14773
  • TK 2130 Lübeck, Schleswig-Holstein, Germany
    • Spinnenerfassung in SH
Re: Quellen im Wiki
« Antwort #13 am: 2009-10-20 23:43:03 »
Habe dem Autor eine E-Mail geschickt.

Martin
« Letzte Änderung: 2009-10-21 09:40:33 von Lars Friman »
Profil bei Researchgate.net

DAS waren noch Zeiten: Nowegen 2011.

Martin Lemke

  • Administrator
  • *****
  • Beiträge: 14773
  • TK 2130 Lübeck, Schleswig-Holstein, Germany
    • Spinnenerfassung in SH
Re: Quellen im Wiki
« Antwort #14 am: 2009-10-21 00:15:34 »
Antwort:
Zitat
I haven't maintained the cite code since 2005 so I'm a bad person to
contact for support on it. I have no idea why this is happening but it
looks really strange.

You should contact one of the mediawiki mailing lists about this issue
or file a bug in bugzilla.

Schlechte Aussichten.

Martin
Profil bei Researchgate.net

DAS waren noch Zeiten: Nowegen 2011.

Jörg Pageler

  • Gast
Re: Quellen im Wiki
« Antwort #15 am: 2009-10-21 19:20:50 »
Moin Martin,

ich habe mir gerade gefühlte 2000 "zufällige Seiten" im Wiki angesehen.
Folgendes ist mir aufgefallen (etwas umständlich zu erklären, zumal ich von solcher Software keinen Schimmer habe):
Sobald weniger als vier Überschriften vor Quellen (im Quelltext: ==Quellen==), gleich formatiert sind, sind die Quellenangaben sichtbar. Doch sobald es mehr sind, wie z.B...

==Merkmale==
==Familie==
==Gattungen==
==Netzbau==
==Weblinks==

...erscheinen die Quellenangaben nicht.
Ausnahme z.B.: Linyphiidae, wo hinter den mit ==XXX== formatierten Abschnitten noch ===Weitere Gattungen=== (also eine andere "Überschriften-Kategorie") eingefügt ist.
Wie gesagt: Ich bin bei sowas bar jeder Ahnung, und natürlich habe ich mir auch längst nicht jede Seite angesehen und daraufhin geprüft, aber könnte das Problem vielleicht etwas damit zu tun haben?

Jörg

Lars Friman

  • Gast
Re: Quellen im Wiki
« Antwort #16 am: 2009-10-21 19:30:14 »
Moin Jörg,
ich wusste doch, dass Du noch Student bist und unendlich viel Zeit hast!
Lars Friman

Arno Grabolle

  • ******
  • Beiträge: 14437
    • mein g+
Re: Quellen im Wiki
« Antwort #17 am: 2009-10-21 21:13:33 »
Jörg, der Hinweis klingt gut und sehr Wertvoll!

Arno

Martin Lemke

  • Administrator
  • *****
  • Beiträge: 14773
  • TK 2130 Lübeck, Schleswig-Holstein, Germany
    • Spinnenerfassung in SH
Re: Quellen im Wiki
« Antwort #18 am: 2009-10-22 01:48:14 »
Über Lars' Kommerntar kriege ich mich nicht mehr ein vor Lachen.

Danke, Jörg, für den Versuch der Analyse. Wenn das stimmt, ist es ein niederschmetternder Befund, weil irrational.

Kurzfristig werde ich keine Lösung bieten können. Eine Idee wäre, die Extension Cite selber ganz neu zu implementieren. Bei der Gelegenheit könnte man gleich ein paar Mängel beseitigen. Aber mittelfristig wird das nichts. Eher langfristig.

Möglicherweise ist es aber doch effizienter zu versuchen, den Fehler im Source zu finden. Wenn der Autor aber abwinkt, wer soll es dann richten? An eine rettende Intiative der Mailinglist glaube ich nicht.

Martin
Profil bei Researchgate.net

DAS waren noch Zeiten: Nowegen 2011.

Bastian Drolshagen

  • ****
  • Beiträge: 1153
  • MTB 6916 FTW!!!
    • Dipluridae.de
Re: Quellen im Wiki
« Antwort #19 am: 2009-10-22 07:24:06 »
ich wusste doch, dass Du noch Student bist und unendlich viel Zeit hast!

höy :-(

Michael Hohner

  • Administrator
  • *****
  • Beiträge: 4848
  • Wo ist nun der versprochene Wurm?
    • Meine Spinnenfunde in Bayern
Re: Quellen im Wiki
« Antwort #20 am: 2009-10-22 09:24:45 »
Also, einen "rationalen" Bug habe ich noch nie gesehen...

Cite neu zu implementieren halte ich fuer sinnlos, solange man den Bug nicht dort lokalisiert hat.

Mach doch einfach mal das Update auf 1.15.1 (ist ja nur ein Patch, kein Vollupdate). Das kann zumindest nicht schaden.

Martin Lemke

  • Administrator
  • *****
  • Beiträge: 14773
  • TK 2130 Lübeck, Schleswig-Holstein, Germany
    • Spinnenerfassung in SH
Re: Quellen im Wiki
« Antwort #21 am: 2009-10-22 11:16:57 »
Mach doch einfach mal das Update auf 1.15.1 (ist ja nur ein Patch, kein Vollupdate). Das kann zumindest nicht schaden.

Kurzfristig wird auch das nichts. Ich muss mein Engagement in allen Dingen bis Mitte November runter fahren, bzw. ruhen lassen.

Martin
Profil bei Researchgate.net

DAS waren noch Zeiten: Nowegen 2011.

Katja Duske

  • Kerngruppe
  • ******
  • Beiträge: 4242
Re: Quellen im Wiki
« Antwort #22 am: 2009-10-22 14:11:50 »
Bei Malthonica ferruginea steht bei Quellen folgende Fehlermeldung:

   1. ^ Referenz-Fehler: Ungültiger <ref>-Tag; es wurde kein Text für das Ref mit dem Namen platnick angegeben.

Angemeldet stehen da 12 Quellen und der Platnick ist auch da.

Kann da vielleicht jemand was mit anfangen?

LG Katja

Katja Duske

  • Kerngruppe
  • ******
  • Beiträge: 4242
Re: Quellen im Wiki
« Antwort #23 am: 2009-10-22 14:40:36 »
Bei Atypus piceus gibt es mehr als 4 Überschriften und eine Quellenangabe erscheint. Allerdings müßten es mehrere sein.

LG Katja


Martin Lemke

  • Administrator
  • *****
  • Beiträge: 14773
  • TK 2130 Lübeck, Schleswig-Holstein, Germany
    • Spinnenerfassung in SH
Re: Quellen im Wiki
« Antwort #25 am: 2009-10-23 13:17:00 »
http://www.mediawiki.org/wiki/Extension:Cite/Cite.php#Users_without_edit_privileges_can.27t_see_references_if_sysops_can

In unserer LocalSettings.php existiert diese Zeile nicht:
$wgGroupPermissions['sysop']['edit'] = true;

wohl aber
$wgGroupPermissions['user']['edit'] = true;

Darauf können wir auch nicht verzichten, denn dann könnte niemand von uns mehr am Wiki etwas ändern.

Testhalber habe ich die Zeile aber mal auskommentiert. Unangemeldet waren die Zitate dennoch nicht zu sehen.

Martin
Profil bei Researchgate.net

DAS waren noch Zeiten: Nowegen 2011.

Michael Hohner

  • Administrator
  • *****
  • Beiträge: 4848
  • Wo ist nun der versprochene Wurm?
    • Meine Spinnenfunde in Bayern
Re: Quellen im Wiki
« Antwort #26 am: 2009-10-23 14:07:59 »
Auf der referenzierten Seite steht aber was anderes, naemlich

Zitat
A current work-around is to set

$wgGroupPermissions['*']['edit'] = false;

and not grant any editing rights to sysops. Users who are sysops would then need to be part of another group with editing privileges.

Da steht nicht, dass man $wgGroupPermissions['user']['edit'] = true; auskommentieren soll.

Martin Lemke

  • Administrator
  • *****
  • Beiträge: 14773
  • TK 2130 Lübeck, Schleswig-Holstein, Germany
    • Spinnenerfassung in SH
Re: Quellen im Wiki
« Antwort #27 am: 2009-10-24 08:02:01 »
Da steht nicht, dass man $wgGroupPermissions['user']['edit'] = true; auskommentieren soll.

In welcher Weise soll ich das denn nun richtig verstehen?

Martin
Profil bei Researchgate.net

DAS waren noch Zeiten: Nowegen 2011.

Michael Hohner

  • Administrator
  • *****
  • Beiträge: 4848
  • Wo ist nun der versprochene Wurm?
    • Meine Spinnenfunde in Bayern
Re: Quellen im Wiki
« Antwort #28 am: 2009-10-24 08:32:42 »
So wie ich das verstehe, sollte man folgendes setzen:

$wgGroupPermissions['*']['edit'] = false;

$wgGroupPermissions['sysop']['edit'] = false;

(oder letztere Zeile komplett entfernen).

Die Permissions für normale User bleiben wie sie sind. Wenn ein Sysop trotzdem noch editieren können soll, dann muss er noch in einer anderen Gruppe mit Editrechten Mitglied sein.

Martin Lemke

  • Administrator
  • *****
  • Beiträge: 14773
  • TK 2130 Lübeck, Schleswig-Holstein, Germany
    • Spinnenerfassung in SH
Re: Quellen im Wiki
« Antwort #29 am: 2009-10-24 09:56:43 »
$wgGroupPermissions['*']['edit'] = false;

$wgGroupPermissions['sysop']['edit'] = false;

(oder letztere Zeile komplett entfernen).

Diese Zeile existiert in unserer Konfiguration gar nicht. Deshalb der Gedanke, dass dieses Problem auch bei
$wgGroupPermissions['user']['edit'] auftritreten könnte. Das hatte ich testen wollen.

Ich habe versäumt, darauf hinzuweisen.

Bei Atypus piceus gibt es mehr als 4 Überschriften und eine Quellenangabe erscheint.

Danke, Katja, für diese Beobachtung.

Bei scheinbar sporadisch auftretende Fehlern hat man kaum eine Möglichkeit, die Ursache zu eruieren. Ich sehe nur eine Lösung in der Reimlemantation, bzw. Neuerfindung des Moduls. Mal sehen, wie lang der Winter wird.

Martin
Profil bei Researchgate.net

DAS waren noch Zeiten: Nowegen 2011.